考えるより感じろって考えてたとこ

この記事は whywaita Advent Calendar 2020 の13日目の記事です。 昨日は nersonuさんの

nersonu.hatenablog.com

でした。「何をするにもwhywaitaさんの声のデータが無いと始まりません。」に大変共感しました。

永遠のWork In Progress

もうなんもわからん。

(うるさいかもしれません。マスタリング一切してません。。)

使用した素材:Dentoo.LT #7.5 - YouTube

参考にしたサイト(ありがとうございます):【完全初心者向け】アイマスREMIXをやってみよう!入門編①【全部無料で】:Legoのブロマガ - ブロマガ

おわり

本当はメロディーつけて踊るぞ~~~~って感じにしたいんだけど、こういう音で遊ぶのをやってみたのがつい最近なので、もっと修行をしようとおもいます。

(関係ないけど、サービスによって自分の名前がころころ変わってるの今思うと大失敗だなあ…)

明日は id:yu_ki_kun_0 さんです。おたのしみに!

NAPT配下のIX2105でTunnel BrokerのIPv6アドレスを取得する

はじめに

我が家では部屋の壁にLANポートがついており、マンションのインターネット接続サービスが利用できるようになっています。 そこに接続するとマンション管理のプライベートIPv4アドレスが降ってきて、マンションのゲートウェイを経由してインターネットに抜けられます。 このプライベートIPv4アドレスを持ったIX2105とTunnel Broker間でIPv6 over IPv4トンネルを張り、IPv6アドレスを使えるようにします。

f:id:jackson58:20200712150638p:plain
ネットワーク構成図

Tunnel Brokerとは

Tunnel Brokerとは、アメリカのISPの1つであるHurricane Electric社がIPv6アドレスを開発や実験の目的で利用したいユーザーに対して無償で提供してくれるサービスです。 IPv4ネットワークを用いてIPv6 over IPv4トンネルをHE社とユーザーの間で張ることでIPv6ネットワークへの到達性を得ることができます。

Tunnel Brokerへの登録

IPv6アドレスの割り当てをしてもらうため、Tunnel Brokerにユーザー登録を行います。

その後トンネル作成を行います。 このとき自分のIPアドレスを入力する場所がありますが、NAPTで利用されるグローバルIPアドレスを入力します。

f:id:jackson58:20200712151802p:plain
NAPTで使用されるグローバルIPを入力する

IX2105の設定

Tunnel BrokerとのIPv6 over IPv4トンネリング

IPv6アドレスを割り当ててもらうために、Tunnel BrokerとのIPv6 over IPv4トンネリングの設定を行います。

interface Tunnel0.0
  description he.net ipv6
  tunnel mode 6-over-4
  tunnel destination 74.82.46.6
  tunnel source GigaEthernet0.0
  no ip address
  ipv6 address 2001:470:XX:YYY::2/64 ★IPv6 Tunnel EndpointsのClient IPv6 Addressに記載されているv6アドレス
  no shutdown
exit

この時点でIPv6 Tunnel EndpointsのServer IPv6 Address(上記コンフィグを例にすると 2001:470:XX:YYY::1)宛にpingが飛ぶようになります。

LAN側インターフェース

次に自サイトの端末が使用するIPv6アドレスの設定を行います。 ここではGE1.0に対して設定を行います。既にGE1.0に対してIPv4系の設定がしてあっても問題ありません。

ipv6 ufs-cache enable
ipv6 route default Tunnel2.0

interface GigaEthernet1.0
  ipv6 address 2001:470:AA:BBB::1/64
  ipv6 nd ra enable
  ipv6 nd ra managed-config-flag
  ipv6 nd ra other-config-flag
  no shutdown

アクセスリスト

上記までの設定でIPv6での通信ができるようになりましたが、外部から直接アクセスされる状態になっています。 ここでは中から外の通信、ICMPを許可し、外部が起点の通信をブロックする設定を行います。

ipv6 access-list acl-deny deny ip src any dest any
ipv6 access-list acl-icmpv6 permit icmp src any dest any
ipv6 access-list acl-permit permit ip src any dest any
ipv6 access-list dynamic dflt-list access acl-permit

Tunnelインターフェースにアクセスリストを適用します。 GE1のほうに書かないように気を付けてください(端末からIX2105への通信がブロックされます…)

interface Tunnel0.0
  ipv6 filter acl-icmpv6 1 in
  ipv6 filter acl-block 100 in
  ipv6 filter acl-icmpv6 1 out
  ipv6 filter dflt-list 100 out
exit

loggingの設定を行うことでアクセスリストによってブロックされた通信を確認することができます。

logging subsystem flt warn

をした上で、show logging を実行するとログを確認できます。

これで設定完了です。 自端末にIPv6アドレスが降られてるのを確認したらhttp://www.kame.net/ にアクセスしてみてカメが踊っているか確認してみましょう。

おわりに

IPv6 over IPv4トンネルを張るにはグローバルのIPv4アドレスが必要なのかなと思ってたんですが、archwikiを眺めてたらNote: If you are behind a NAT (typical home router setup), use your local IPv4 address for client_IPv4_address, e.g. 192.168.0.2. と記載があり、グローバルアドレスは関係ないと分かったのでIXを使って試してみました。

これを機にIPv6の勉強をしていきたいと思います。

参考

キミと僕とwhywaita

この記事はwhywaita Advent Calendar 2019 14日目の記事です。

昨日はmasawadaさんが39円を贈ってThank youを伝えていましたね。

whywaita Advent Calendar 2019が無事全日埋まったのでお祝いしました

偶然にも昨日はアイドルマスター ミリオンライブ!シアターデイズ(ミリシタ)でもThank you!の39人ライブが実装されましたね。ぜひやりましょう。


キミと出会ったのはおよそ5年前。冬の新宿。

whywaitaくんが紹介してくれました。 当時の僕は特に興味も出ないまま話を聞き、そういう人もいるんだなという感じでその場をあとにしました。

数年たったあるとき、キミと再び会うことになり、何度か会ってみると以前とは違ってとても暖かく魅力的な人になったなあと思いました。

whywaitaくん、あのとき紹介してくれてありがとう。

ご紹介します。

www.youtube.com

如月千早さんです。

あらまし

本AC11日目の記事にも書かれているとおり、whywaitaくんは千早が好きで好きでたまらないそうです。

せっかくですのでこの記事では僕が今プロデュースしている如月千早さんをみなさまにご紹介したいと思います。 …というご紹介記事の形をした僕のアケマスプレイ日記です。

千早の説明としてよく聞くのは「765プロの歌姫」というものです。「歌うことが好き。私には歌しかない。アイドル活動には興味ありません。」

千早については以下のリンクなどをご参照ください(丸投げ)

THE IDOLM@STER [如月千早] https://dic.nicovideo.jp/a/%E5%A6%82%E6%9C%88%E5%8D%83%E6%97%A9

プロデュース状況

f:id:jackson58:20191209200747j:plain
アケマスのカード
Flyers!!という名前の如月千早、菊池真、水瀬伊織の3人ユニットをプロデュースしています。 この写真の時点ではまだ活動7週目の駆け出しアイドルです。

これからどんどんオーディションを受けたり営業活動を行ったりしてファンを増やしていくのはもちろん、それらの活動を通してプロデューサーである僕がアイドルたちのことを知っていき、さらなる信頼関係を築いていくことが必要な段階です。そのためか、まだアイドルたちは不安な部分も多いようです(以下の写真からも表情が曇っていることがわかります)。

f:id:jackson58:20191209200939j:plain
俺も千早に負けないように頑張らなくては

1日の始まりは挨拶から

アケマスの1日は朝の挨拶から始まり、夜に事務所で別れの挨拶をして終わります。1日の流れについて詳しくは公式ホームページをご覧ください。

挨拶はとても重要です。挨拶を怠れば礼儀がないと怒られるし数日間口も聞いてもらえない、変に挨拶をすればなんだその態度はと怒られる、などいろいろ大変だと僕の友人の友人が語っていました。つらかった…(僕の友人の友人の話です)。

プロデューサーも例外ではありません。日々挨拶の言葉には工夫を凝らします。

f:id:jackson58:20191209210256j:plain f:id:jackson58:20191209210300j:plain f:id:jackson58:20191209210303j:plain f:id:jackson58:20191209210306j:plain f:id:jackson58:20191209210309j:plain f:id:jackson58:20191209210314j:plain

千早「おはようございます」 P「おはよー!千早!」 千早「は?」

難しいですね。最後の写真の右上にあるハートマークから分かるように、千早のテンションも落ちています。そんなにだめだった…?

なかなか厳しいですが1日は始まったばかりです。お仕事を始めていきましょう。

コミュニケーション

アケマスの進め方としては、オーディションパートとレッスン&コミュニケーションパートの2種類があります。本記事では後者、特にコミュニケーションパートを扱います(オーディションとかレッスンはプレイ中に写真撮れないからね…)

レッスンを終えたアイドルたちは次にプロモーションなどの営業活動を行います。コミュニケーションパートではこの営業活動自体にフォーカスを当てる場合と、その前後の移動中のような日常の風景にフォーカスを当てるパターンがあります。3つ提示される選択肢から1つ選択し(以下の画像)、それを行うアイドルを1人選択するシステムになっています。コミュニケーションがうまくいけば「パーフェクトコミュニケーション」、まあまあであれば「グッドコミュニケーション」、普通であれば「ノーマルコミュニケーション」、機嫌を損ねた場合は「バッドコミュニケーション」です(詳細は公式ホームページをご覧ください)。

f:id:jackson58:20191209210603j:plain

ここでは雑誌のインタビューを受けたあとの千早を見ていきましょう。

落ち込む千早

f:id:jackson58:20191209211304j:plain f:id:jackson58:20191209211315j:plain

音楽雑誌のインタビューなのに音楽の基礎用語が伝わらず話にならないと落ち込んでいるようです。

プロデューサーも一応音楽業界に身を置いている、そう思ったのか、僕は知ってるよ!当然だよね!という気持ちを伝えてみたくなったのでしょうか。 f:id:jackson58:20191209211323j:plain

何もわからない、僕は雰囲気で音楽業界で働いている。

f:id:jackson58:20191209211328j:plain f:id:jackson58:20191209211332j:plain

どうやら正解を当てられたようです。なんとかお前は小学生以下と言われなくて済みました。

その後、音楽理論は作曲者の考えを読むうえで大事だと力説する千早。それを知らないなんてプロとして失格だし、さっきの記者には「知識はあっても、おまえみたいに華のないアイドルは、TVじゃ成功しない」と捨て台詞を吐かれてしまったそうです。その言葉に引っ掛かり、自分の価値は一体何なのかと問いだします。

f:id:jackson58:20191209211412j:plain f:id:jackson58:20191209211424j:plain f:id:jackson58:20191209211428j:plain

相手は15歳の女の子です。これは責任重大です。自分の価値とは、何のために生まれて何をして生きるのか、…。

f:id:jackson58:20191209211433j:plain このあと身体の部位をタッチして選ぶイベントが発生します(写真撮り忘れた。。)

千早は何よりも歌が好きな女の子です。価値は1つではないかもしれませんが、今の千早に伝えられるとしたら…!

f:id:jackson58:20191209211446j:plain f:id:jackson58:20191209211449j:plain これは決まりました。いわゆる「僕はキメ顔でそう言った」ってやつです。

f:id:jackson58:20191209211454j:plain f:id:jackson58:20191209211502j:plain 千早が歌に対して持っている自信を認めてあげることで、さらに自信をつけてもらいその才能をさらに伸ばしていってほしい、そう思いました。

これはいい仕事をしたなあ。僕と千早の絆も深まったはずです。今後も継続して絆を深め、目指せトップアイドル!です。

f:id:jackson58:20191209211504j:plain

……いやいやいやいや。なんでいい感じに締まったのにノーマルなの…!?おかしいでしょ…。

乙女心は難しいです…。

XBox版の攻略サイトを見てもらえば何がパーフェクトかわかりますので興味があれば調べてみてください)

アケマス以降の千早

ここまではアケマスの千早を見ていきました。なかなかに尖っています。とても繊細な女の子です。 こちらの記事にもあるにある通り、千早はとても攻略が難しいアイドルと言われています。

そんな千早に僕がどうして興味を持つようになったのか。 冒頭でも書いた通り、出会った当初(劇場版アイマス公開直後)は特に興味がなかったのです。 ですが、再会するにつれて(ミリオンライブを始めて見る回数が増えた)千早が楽しそうに歌っているなと感じるようになりました。

それを初めて感じたのは2017年の台湾ライブでの"Eternal Harmony"でした。 ライビュ後、この心に残る幸せな気持ちはなんだろうと考えたところ、エタハモでの千早がとっても楽しそうだったから、というのが一番大きいのではないのかと。

アケマスの頃は歌うことしかなかった千早も、アニマスで他のメンバーとの絆が深まったり段々と歌が認められたり、さらには後輩という新たな出会いもありました。 様々な変化の中で千早は気付きを得ては自問自答を繰り返し、先ほどのコミュにあったような問いに対する回答を更新していったのかなと想像しています。 「私は歌わないといけない」という気持ちだった頃から、もっともっと純粋に歌うことを楽しめるようになったのかなあ、そんな姿を台湾のEternal Harmonyでは見ることが出来たのかな、と。 (いちおうアケマスやその後のシリーズはパラレルワールドということになっている*1ので、様々な変化~のくだりは関係ないのかもしれません)

本記事では千早の尖ってる部分のみをお見せしたかもしれませんが、もちろんそれ以外の表情もありますので、ぜひともコンテンツに触れていただければなと思います。

おわりに

アイドルマスターは来年に15周年を迎えます。プロデューサーの涙腺はガバガバとはよく言いますが、15年分のアイドルの成長を見守っているとふと感極まるタイミングがあるのでしょう。僕も感極まってしまった1人です。

そんな僕のプロデュース活動のスタートは、whywaitaくんが2014年頭に劇場版アイマスを見に行こう!と誘ってくれたときなのです。アイドルマスターに出会えたのは彼のおかげです。ありがとう。

…この記事を書こうと思った理由、千早を見てたらなぜかwhywaitaの顔が浮かんで腹立つから、というのは秘密です。

明日はneotasoさんです。

おまけ

アケマスが稼働した2005年頃~2010頃のアイマスのWebページが歴史を感じさせるものばかりだったのでリンクを張っておきます。時代的にFlashが必要です。

ミリシタのイベントを走ったら1000位以内に入ったときの記録

はじめに

この記事では,ミリシタで2018/12/04(火)15:00 ~ 2018/12/12(水) 20:59に行われた「プラチナスターシアター~PRETTY DREAMER~」というイベントを走ったときのスクショが意外とあったので,せっかくなのでそのときの私の心情とともにまとめていきます.
思い出語りなのでやや長め&画像多めです.

続きを読む

Windows10からIX2215へのL2TP/IPsec VPN接続に失敗するときにやったこと

はじめに

NECVPNルータであるUNIVERGE IXシリーズにL2TP/IPsec機能を設定した際、MaciPhoneからは接続できるのにWindows10からは接続できなかった(「セキュリティ層でリモートコンピュータと互換性のあるパラメーターをネゴシエートできなかったため、L2TP接続に失敗しました」というエラー)。IX2215だけではなくIX2105とかでも同じだと思う。

適当に調べるとレジストリを変更してNAT越えに対応する記事が非常に多かったが、それでは解決しなかった。

そこでWindows10上でパケットキャプチャを行いVPN接続ができない原因を調査した。

結論

IXのリファレンス通りにやるとIPsecの鍵交換時に必要なプロポーザルが足りないようだった。 AES 256bit, SHA-1 2048bit(DH group 14)をIX側で使用するように設定すると通った。 config的には

Router(config)# ike proposal ike4 encryption aes-256 hash sha group 2048-bit

を打ち込めば接続できた。

環境

  • IX2215: IX Series IX2215 (magellan-sec) Software, Version 9.4.17
  • Windows10 Pro 1803(ビルド 17134.345)

原因の調査

Wiresharkのフィルタに udp.port == 4500 or udp.port == 500 を入れるといい感じに鍵交換のパケットだけが見られる。

まず最初のパケット(クライアント→VPNサーバ)を見てみる。 その中でも1枚めの画像の赤線の部分の中にプロポーザルが格納されている。 f:id:jackson58:20181111201433p:plain Security Associationの中身。 f:id:jackson58:20181111201553p:plain

Proposal transforms にはプロポーザルの数が格納されており、その後に具体的な内容が格納されている(Payload: Transform (3) #1, #2, #3...)。

私の環境では以下のプロポーザルが格納されていた。

  • AES-CBC 256-bit, SHA ECP 384-bit
  • AES-CBC 128-bit, SHA ECP 256-bit
  • AES-CBC 256-bit, SHA DH Group 14(2048-bit)
  • 3DES-CBC, SHA DH Group 14(2048-bit)
  • 3DES-CBC, SHA DH Group 2(1024-bit)

IXのリファレンスでは以下のようになっていた。

  • AES-CBC 256-bit, SHA DH Group 2(1024-bit)
  • AES-CBC 128-bit, SHA DH Group 2(1024-bit)
  • 3DES-CBC, SHA DH Group 2(1024-bit)

今回の環境下でのIXではハッシュアルゴリズムとしてSHAのECPが設定できないようなので、IX側にAES-CBC 256-bit, SHA DH Group 14(2048-bit)が使えるように設定をすればいいようだった。

また、Windows10側でのVPN接続は以下のように設定した。 f:id:jackson58:20181111202944p:plain

「データの暗号化」の部分で 暗号化が必要(サーバが拒否する場合は切断します)にしたところ、「ローカル コンピュータでは、要求されたデータの暗号化の種類はサポートされません。」というエラーが発生した。

余談

意外なところにIPsecの細かなパラメータ設定するところがあったのが発見でした。

既存のDHCPサーバが存在する場合でもPXE Bootをする(dnsmasqを使ったProxy DHCPの設定)

はじめに

PXE BootをするためにはDHCPサーバにブート情報を設定する必要があるが,Buffalo等の家庭用ルータが設置してあるとこれができない.だからといって別途サブネットを分けたりするのも面倒.

そこで,Proxy DHCPという仕組みを使うと,既存のDHCPサーバの設定を変更せずにブート情報を流すことができる. (参考:PXEには3種類ある

今回はdnsmasqを使ってProxy DHCPの設定を行う.

環境

  • サブネット:192.168.11.0/24
  • Proxyサーバ(dnsmasq):192.168.11.100
  • TFTPサーバ:192.168.11.201
  • (既存のBuffaloルータ:192.168.11.1)

ブートの流れ

  1. PXE ClientがDHCP要求を行う
  2. 既存のDHCPサーバ(Buffaloルータ)が応答する(DHCP Offer)
  3. Proxyサーバ(dnsmasq)がnext-serverとbootfile-nameを載せて応答する(DHCP Offer)
  4. PXE Clientが既存DHCPサーバに対してDHCP Requestを行う
  5. 既存DHCPサーバがDHCP Ackを返す
  6. PXE ClientがProxyサーバに対してDHCP Requestを行う
    • ClientとProxy間はポート4011/UDPが使用される
  7. Proxyサーバがnext-serverとbootfile-nameを載せてACKを返す
  8. PXE ClientがTFTPサーバへアクセスする

dnsmasqの設定

(参考:PXE Server on Existing Network (DHCP Proxy) with Ubuntu | manski's blog

ここではTFTPサーバの設定方法は割愛する.

  • /etc/dnsmasq.conf に以下を追記
port=0
log-dhcp
dhcp-range=192.168.11.0,proxy
dhcp-boot=pxelinux.0,192.168.11.201
pxe-service=x86PC,"Network Boot",pxelinux,192.168.11.201

ここでpxe-service オプションにTFTPサーバのIPアドレスを書かないと,next-serverにProxyサーバIPアドレスが設定されてしまうので注意. dhcp-bootにしか書かないと”ブートの流れ”の3と7でnext-serverのIPアドレスが変わり,PXEブートに失敗する. (参考:[Dnsmasq-discuss] dnsmasq dhcpProxy and PXE next-server not working

あとはdnsmasqを再起動すれば設定完了.

パケットキャプチャしてみた

PXEブート時のDHCPパケットをキャプチャするとこのようになった.

f:id:jackson58:20180531185459p:plain

192.168.11.26PXE Clientに割り当てられたIPアドレス

4011/UDPの通信はプロトコルBOOTP/DHCPに変えてあげることでパースしてくれる. f:id:jackson58:20180531185858p:plain

VyOSでPXEサーバの設定をする

VyOS 1.1.8でのPXEサーバの設定方法をメモ.

設定前のDHCP Serverのコンフィグ

ネットワーク名は win-ad としている.

vyos@vyos# show service dhcp-server shared-network-name win-ad  
 subnet 10.76.5.0/24 {                                          
     default-router 10.76.5.254                                 
     dns-server 10.76.5.1                                       
     domain-name 765pro.local                                   
     start 10.76.5.2 {                                          
         stop 10.76.5.50                                        
     }                                                          
 }                                                              

必要なコンフィグ

  • bootfile-server
    • next-server を指定する
  • bootfile-name
    • ブートストラップファイルの名前を指定
vyos@vyos# set service dhcp-server shared-network-name win-ad subnet 10.76.5.0/24 bootfile-server 192.168.11.201
vyos@vyos# set service dhcp-server shared-network-name win-ad subnet 10.76.5.0/24 bootfile-name pxelinux.0

おわり

最初は shared-network-parametersfilename "pxelinux.0"を指定してあげればいいのかなと思ったけど,ダブルクオートが入ってるというのでエラーが起きて妙に悩んでしまった. 結構簡単にできるじゃん.